Cannot runLog : job locally: Number of reducers (= 3) is more than 1
On Single Node Hadoop Cluster, any Hive databases query gives log “Cannot run job locally: Number of reducers (= 3) is more than 1” and goes into pending state . running the map reduce job is in...
View Articlesmoke test MapReduce hung
su – $CLIENT_USER /usr/hdp/current/hadoop-client/bin/hadoop jar /usr/hdp/current/hadoopmapreduce- client/hadoop-mapreduce-examples-*.jar teragen 10000 tmp/ teragenout gave WARN: WARN...
View ArticleReply To: Insert overwrite for 2 GB data
Hi Sandeep, Your question would be best answered here: http://hortonworks.com/community/forums/forum/hive/ Please post your question there. Regards, Robert
View ArticleHive does not group splits when used with oozie
Hi, I am trying to run a hive process using oozie and it is taking too long to process. The normal hive query takes about 35 min and when scheduled with oozie it takes 2 hours 45 minutes. I checked...
View ArticleDelete previous version of HDP software
Our cluster was upgraded from HDP 2.3.0 to 2.3.2. We’re trying to determine the best way to remove the old software stack. Is there any supported way to remove all references to HDP 2.3.0 from Ambari?...
View ArticleReply To: DataNode not started after changing the datanode directories parameter
I found the workaround of this problem, I mounted the disk to the to the /mnt/sdb folder, and this folder I use as the datanode directories entry. But if create the /mnt/sdb/data and use it as entry...
View Articlei need to know the path for files under Sandbox filebrowser
Dears , i am working currently on the SandBox , i have windows system and the sandbox is Hyper-V machine , from the browser i have uploaded a files under filebrowser. Ex: Home\User\Hue\ using...
View ArticleDataNode not started after changing the datanode directories parameter
Hello, I have added the new disk to the hortonworks OracleVM, following this example. https://muffinresearch.co.uk/adding-more-disk-space-to-a-linux-virtual-machine/ I set the owner of the mounted...
View ArticleReply To: Sqoop Jobs with Oracle Wallet
Hi all, The error i’m facing has changed to java.sql.SQLException: ORA-01017: invalid username/password; logon denied Waiting for your comments.
View ArticleReply To: Hive view cannot connect – Error H020
I suspect that the Ambari view does not understand how to obtain or forward LDAP authorization. After reinstalling the cluster from scratch and leaving authorization at the default (Unix permissions,...
View ArticleData Node lost heart beat, not able to recover ir in the hadoop cluster.
Hi, I have a 4 node HDP cluster with Ambari 2.3. The cluster was live and working fine until couple of days back, when other installation on one of the data nodes happened. In the UI is shows all the...
View ArticleHive view cannot connect when using http transport mode
I’m using Sandbox 2.3.2 I have configured Hive with hive.server2.transport.mode=http (because of Knox integration). However, the Hive view in Ambari does not seem to like that. When I leave it at the...
View ArticleReply To: Pig view fails HDFS check in Kerberos environment
Found the issue. In the cluster configuration settings, I was using the default Ambari managed cluster (Sandbox). Changed it to custom and set WebHDFS FileSystem URI and WebHCat Hostname to use FQDN....
View ArticleReply To: Hive view cannot connect – Error H020
Hi All, I am facing same issue.I have configured LDAP on hiveserver2 and able to connect through beeline but unable to connect by using ambari views. I have also configured ambari for LDAP but still...
View Articleservice start issue
Hi team , I have installed HDP 2.3.2 in a 5 node cluster using local repo and ambari automated install. I am not able to start the data node service but all of them are getting installed. Can any one...
View ArticleReply To: Cannot see Advanced options on the Hortonworks welcome screen
Try disabling your Ad blockers such as Ghostery.
View Articlejoin performance
There are 3 tables. client table only having 300 records. I need this table to get client name. person_detail table is having 180 million records and partition on client_id field. person_detail table...
View ArticleInsert overwrite for 2 GB data
I am running insert overwrite table emp_rc partition(year) select *,year_num from table1; table1 size is 1.8 GB and this table is textfile, while emp_rc is RCFile. When i run this sql, it takes 1...
View ArticleReply To: Ambari 2.1.2 chown message when starting agents
I’m having the same issue. did you find a solution? Kind Regards
View ArticleReply To: Do you need to know Java to learn Hadoop?
You’ve posted this in the Hive/HCatalog forum. Although that tool is written in Java you don’t need to know any java to use it. The same is true for most of the rest of Hadoop. You do need to know...
View Article